WiringPi Python not working on BPI-M2 (Raspbian)


(Martin) #1

Hi, I’m having error with WiringPi Python on BPI-M2.

bananapi@BPI-M2 ~/ports/BPI-WiringPi2-Python $ sudo python test.py Unable to determine hardware version. I see: Hardware : sun6i ,

Can you please let me know how to make it work? I’m using Raspbian. Regards Martin


(BPI_Justin) #2

Hi, The WiringPi2 Python currently supports M1/M1 Plus only; M2 has not yet been supported. We’ll get the code done to support M2 as soon as we can.


(Marko) #3

Hi Justin,

I am having the same problem on BPI-M2, I am using Ubuntu for M2.

Unable to determine hardware version. I see: Hardware   : sun6i
,
 - expecting BCM2708 or BCM2709. Please report this to projects@drogon.net

I see that here https://github.com/BPI-SINOVOIP/BPI-WiringPi2-Python says that it supports M2? Is this still not the case?

If so can you please let us know when can we expect update to support M2?

Regards, Marko


(BPI_Justin) #4

Hi: the WiringPi2 Python for M2 is still under test, not ready to release yet. We’ll do all we can to get it done for everyone as soon as possible.