Wireless not working


(Tim) #1

I am using armbian 18.04 stretch. Got the following errors. What are they? Wi-fi and bluetooth both are not working. Could someone help, Thanks!

[    7.470412] cfg80211: failed to load regulatory.db
[    7.487790] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-11), device may have limited channels available
[    7.492644] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM43430/1 wl0: Mar 30 2016 11:30:56 version 7.45.77.h8.4 FWID 01-ee8a6268
[    8.034378] EXT4-fs (zram0): mounted filesystem without journal. Opts: discard
[    8.160346] random: crng init done
[    8.160357] random: 7 urandom warning(s) missed due to ratelimiting
[   12.045134] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   12.052109] RTL8211E Gigabit Ethernet stmmac-0:01: attached PHY driver [RTL8211E Gigabit Ethernet] (mii_bus:phy_addr=stmmac-0:01, irq=POLL)
[   12.054167] dwmac-sun8i 1c50000.ethernet eth0: No Safety Features support found
[   12.054186] dwmac-sun8i 1c50000.ethernet eth0: No MAC Management Counters available
[   12.054195] dwmac-sun8i 1c50000.ethernet eth0: PTP not supported by HW
[   12.054741] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   12.095282] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   14.843874] brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout
[   17.403865] brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout
[   17.403884] brcmfmac: brcmf_dongle_scantime: Scan assoc time error (-110)
[   19.963823] brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout
[   19.963837] brcmfmac: brcmf_netdev_open: failed to bring up cfg80211
[   22.523835] brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout
[   22.523850] brcmfmac: brcmf_cfg80211_get_channel: chanspec failed (-110)
[   25.083827] brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout
[   25.083838] brcmfmac: brcmf_cfg80211_get_tx_power: error (-110)
[   27.899841] brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout
[   27.899859] brcmfmac: brcmf_cfg80211_get_channel: chanspec failed (-110)
[   30.459855] brcmfmac: brcmf_proto_bcdc_query_dcmd: brcmf_proto_bcdc_msg failed w/status -110
[   30.459869] brcmfmac: brcmf_cfg80211_get_tx_power: error (-110)
[   33.019910] brcmfmac: brcmf_proto_bcdc_query_dcmd: brcmf_proto_bcdc_msg failed w/status -110
[   33.019925] brcmfmac: brcmf_cfg80211_get_channel: chanspec failed (-110)
[   33.579686] fuse init (API version 7.27)
[   35.579912] brcmfmac: brcmf_proto_bcdc_query_dcmd: brcmf_proto_bcdc_msg failed w/status -110
[   35.579926] brcmfmac: brcmf_cfg80211_get_tx_power: error (-110)
[   38.139845] brcmfmac: brcmf_proto_bcdc_query_dcmd: brcmf_proto_bcdc_msg failed w/status -110
[   38.139859] brcmfmac: brcmf_cfg80211_get_channel: chanspec failed (-110)
[   38.586584] EXT4-fs (mmcblk1p8): mounted filesystem with ordered data mode. Opts: (null)
[   38.767733] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[   39.384089] EXT4-fs (mmcblk1p1): mounted filesystem with ordered data mode. Opts: (null)

(Tim) #2

Armbian 5.66 5.69 both are not working. Neither wifi nor bluetooth, even worse on no hdmi for 5.69. If you use 5.69, you have to use TTL serial port to connect console.