Sunxi-bt bt: block state already is 0


#1

Hi, i’m running latest jessie image (25/05) and the syslog is filled with the error sunxi-bt bt: block state already is 0.

This message comes every 5 seconds. I think it is related to bluetooth.

the command rfkill list all returns:

0: sunxi-bt: Bluetooth Soft blocked: no Hard blocked: no 1: phy0: Wireless LAN Soft blocked: no Hard blocked: no 2: brcmfmac-wifi: Wireless LAN Soft blocked: no Hard blocked: no 4: hci0: Bluetooth Soft blocked: no Hard blocked: no

I’m not sure what this means but it looks like there are 2 bluetooth devices hci0 and sunxi-bt.

I am not using bluetooth or the raspbian GUI as i am running headless as a NAS.

How can i configure sunxi-bt so that it does not start or fix the error block state already is 0?

thanks!


#2

Did a clean install of the latest jessie image (25-05-17) and the issue with sunxi-bt logging every 5 seconds.

Below is an extract from syslog after a reboot

[ 1.395932] sunxi-bt bt: bt_power_name (vcc-wifi-2) [ 1.395945] sunxi-bt bt: io_regulator_name (vcc-io-wifi) [ 1.395969] sunxi-bt bt: bt_rst gpio=236 mul-sel=1 pull=1 drv_level=1 data=0 [ 1.396012] sunxi-bt bt: clk_name (outa) [ 1.396337] sunxi-bt bt: block state already is 1 [ 5.647985] sunxi-bt bt: set block: 0 [ 5.649423] sunxi-bt bt: check bluetooth bt_power voltage: 3300000 [ 5.650907] sunxi-bt bt: check bluetooth io_regulator voltage: 3300000 [ 9.189457] sunxi-bt bt: block state already is 0 [ 14.195842] sunxi-bt bt: block state already is 0 [ 19.204285] sunxi-bt bt: block state already is 0 [ 24.215782] sunxi-bt bt: block state already is 0 [ 29.227283] sunxi-bt bt: block state already is 0 [ 34.238345] sunxi-bt bt: block state already is 0

Any ideas how to fix/resolve this? it’s filling the log and I can’t stop it…

Happy to disable BT altogether as not using it. Also not using wi-fi so happy to try disabling either or both…


#3

Is anyone else getting this issue? Any ideas of how to fix would be appreciated…


#4

Good luck with ‘vendor supplied OS images’ that received obviously no testing and are not even supported by their own creators :slight_smile:


#5

haha. that is the feeling I am getting! what are my options though? I’m not able to create/build images myself.

it’s a bit strange that no-one from the vendor team responds to questions and issues.


#6

That’s normal for sinovoip. If you’re a long time Banana user you know this since years, they simply not respond to problems/questions (or tell you ‘just wait’ and never come back, I had a lot of laughs doing a travel back in time the last hour eg. http://web.archive.org/web/20150731025431/http://www.bananapi.com:80/index.php/forum/general-discussion-for-bpi-m2/411-m2-gpio-defininiton – well back at that time I was so pissed off that I just stopped using their boards and left. Scary to see nothing changed years later)

Seems you need a lot of patience or start to head over where some information and resources about community activity is collected: https://forum.armbian.com/index.php?/topic/2884-the-new-banana-pi-m2-ultra/

Edit: maybe it’s just total lack of understanding: Serial port path


#7

I don’t know how to disable Bluetooth (just got the board; Banana Pi M2 Berry) but to get rid of the dmesg errors:

sudo nano /usr/local/bin/bt-raspbian.sh

Then remove or comment-out the while loop:

#while true; do
#       rfkill unblock bluetooth
#        sleep 5
#done

Save the file and reboot. I’m sure this script is called from somewhere but I haven’t found that yet…


#8

@rtje - good find and thanks for posting. Not sure if the code you have commented out is used for anything ‘if’ you are using BT.

I found a work-a-round that just prevents the messages being logged.

You need to configure rsyslog to not log these messages - note it does not fix/resolve the root cause

nano /etc/rsyslog.conf add the following at top of rules section

'#

'# Custom entries to filter out log entries that should not be logged

'#

:msg, contains, “sunxi-bt bt: block state already is 0” ~


#9

@jata - rfkill is used to enable/disable wireless devices and the root cause of the message is actually rfkill itself that tries to unblock the device while it is already unblocked. So the proper solution would be to change the script to this:

while true; do
	if [ ! -z "`rfkill list | grep -A 1 'sunxi-bt: Bluetooth' | grep 'Soft blocked: yes'`" ]; then
		rfkill unblock bluetooth
	fi
        sleep 5
done

Now BT can still be used without the dmesg errors.


#10

that is really helpful. thanks. I will make the change you suggest.

Thanks for helping with this - really appreciated.