(precompiled) Kernels for BPI-R2


(victors) #61

You precompiled 4.14.55-bpi-r2-main


(Frank W.) #62

Not kernel…the image (debian stretch,jessie,ubuntu 14.4,16.4,18.4) my image or official


(victors) #63

You debian stretch .


(Frank W.) #64

tested 4.14.56 with ubuntu:

Ubuntu 18.04 LTS bpi-r2-ubuntu ttyS0                                            
                                                                                
bpi-r2-ubuntu login: root                                                       
Password:                                                                       
Last login: Sat Jul 21 15:05:44 CEST 2018 on ttyS0                              
Welcome to Ubuntu 18.04 LTS (GNU/Linux 4.14.56-bpi-r2-main armv7l)              
                                                                                
 * Documentation:  https://help.ubuntu.com                                      
 * Management:     https://landscape.canonical.com                              
 * Support:        https://ubuntu.com/advantage                                 
                                                                                
root@bpi-r2-ubuntu:~# lsmod                                                     
Module                  Size  Used by                                           
mtk_thermal            16384  0                                                 
mt6577_auxadc          16384  0                                                 
thermal_sys            61440  1 mtk_thermal                                     
mtk_pmic_keys          16384  0                                                 
nvmem_mtk_efuse        16384  0                                                 
spi_mt65xx             20480  0                                                 
rtc_mt6397             16384  1                                                 
pwm_mediatek           16384  0                                                 
ip_tables              24576  0                                                 
x_tables               28672  1 ip_tables                                       
ipv6                  417792  22                                                
root@bpi-r2-ubuntu:~# [  OK  ] Stopped target Timers.                           
[  OK  ] Stopped target Host and Network Name Lookups.                          
[  OK  ] Stopped Discard unused blocks once a week.                             
         Stopping User Manager f[  OK  ] Stopped Regular background program pro.
[  OK  ] Stopped Dispatcher daemon for systemd-networkd.                        
[  OK  ] Stopped System Logging Service.                                        
[  OK  ] Stopped Serial Getty on ttyS0.                                         
[  OK  ] Stopped OpenBSD Secure Shell server.                                   
[  OK  ] Stopped Getty on tty1.                                                 
[  OK  ] Stopped User Manager for UID 0.                                        
[  OK  ] Stopped D-Bus System Message Bus.                                      
[  OK  ] Stopped Session c1 of user root.                                       
[  OK  ] Removed slice User Slice of root.                                      
         Stopping Login Service...                                              
[  OK  ] Removed slice system-getty.slice.                                      
[  OK  ] Removed slice system-serial\x2dgetty.slice.                            
         Stopping Permit User Sessions...                                       
[  OK  ] Stopped Permit User Sessions.                                          
[  OK  ] Stopped Login Service.                                                 
[  OK  ] Stopped dnsmasq - A lightweight DHCP and caching DNS server.           
[  OK  ] Stopped target Network.                                                
         Stopping ifup for eth1...                                              
         Stopping ifup for lan0...                                              
         Stopping ifup for wan...                                               
         Stopping Raise network interfaces...                                   
         Stopping ifup for lan3...                                              
         Stopping ifup for lan1...                                              
         Stopping ifup for eth0...                                              
         Stopping ifup for lan2...                                              
[  OK  ] Stopped ifup for eth1.                                                 
[  OK  ] Stopped ifup for lan0.                                                 
[  OK  ] Stopped ifup for wan.                                                  
[  OK  ] Stopped ifup for eth0.                                                 
[  OK  ] Stopped ifup for lan2.                                                 
[  OK  ] Stopped ifup for lan1.                                                 
[  OK  ] Stopped ifup for lan3.                                                 
[  OK  ] Stopped Raise network interfaces.                                      
[  OK  ] Stopped rng-tools.service.                                             
[  OK  ] Stopped target Remote File Systems.                                    
[  OK  ] Stopped target Basic System.                                           
[  OK  ] Stopped target Slices.                                                 
[  OK  ] Removed slice User and Session Slice.                                  
[  OK  ] Stopped target Paths.                                                  
[  OK  ] Stopped target Sockets.                                                
[  OK  ] Closed D-Bus System Message Bus Socket.                                
[  OK  ] Stopped target System Initialization.                                  
         Stopping Update UTMP about System Boot/Shutdown...                     
[  OK  ] Stopped Apply Kernel Variables.                                        
         Stopping Network Time Synchronization...                               
         Stopping Load/Save Random Seed...                                      
[  OK  ] Stopped Load Kernel Modules.                                           
[  OK  ] Stopped target Local Encrypted Volumes.                                
[  OK  ] Stopped Dispatch Password Requests to Console Directory Watch.         
[  OK  ] Stopped Forward Password Requests to Wall Directory Watch.             
[  OK  ] Closed Syslog Socket.                                                  
[  OK  ] Stopped Network Time Synchronization.                                  
[  OK  ] Stopped Load/Save Random Seed.                                         
[  OK  ] Stopped Update UTMP about System Boot/Shutdown.                        
[  OK  ] Stopped Create Volatile Files and Directories.                         
[  OK  ] Stopped target Local File Systems.                                     
         Unmounting /boot...                                                    
         Unmounting /run/user/0...                                              
[  OK  ] Unmounted /boot.                                                       
[  OK  ] Unmounted /run/user/0.                                                 
[  OK  ] Reached target Unmount All Filesystems.                                
[  OK  ] Stopped target Local File Systems (Pre).                               
[  OK  ] Stopped Create Static Device Nodes in /dev.                            
[  OK  ] Stopped Remount Root and Kernel File Systems.                          
[  OK  ] Stopped target Swap.                                                   
[  OK  ] Reached target Shutdown.                                               
[  OK  ] Reached target Final Step.                                             
         Starting Power-Off...                                                  
[   60.151929] reboot: Power down     

here i can powerdown by pressing the power-switch


(Josué) #65

Hello,

Are they any reason to disable the check when you build openssl. I have tried without the option DEB_BUILD_OPTIONS=nocheck and the build failed on the test. So is it normal ?


(xbgmsharp) #66

To my understanding this is because of the cross compile. I more likely did not set correctly all variable to compile tests. In any case, those are only tests and we compile the latest current package version.


(Josué) #67

I compiled this in my board so it might be not that.


(Frank W.) #68

Openssl-option in build.sh is a bit buggy because it refereces a fixed package. Can you cleanup this? Same for cryptodev.

I have changed deb-package-creation so it should be installed correctly via postinst


(xbgmsharp) #69

It does not refer to any fixed package or version. It refers to any deb package format, eg: Debian or Ubuntu. the build.sh use the apt source to build the current openssl version with cryptodev.


(Frank W.) #70

There are problems with version (the folder created)…i can’t get it compiled on ubuntu 14.4


(victors) #71

The issue of turning off the power by power button was successfully solved by installing and configuring the acpid package. This package is not installed by default in the console version of the debian.


(Frank W.) #72

Thank you for testing it out…i currently testing new kernels with ubuntu where my main-router uses debian so i can look in both systems. Maybe i can setup a dualboot-system by setting root-var in uenv.txt :slight_smile:

@josue i try to build openssl direct from git-repo without debian/ubuntu-package (openssl.sh in 4.14-main),but don’t know how to integrate cryptodev-support