No signal on screen


(say_hello) #1

no signal on screen

what can i do now - plz advice


(say_hello) #2

btw i have found some very intersting thread …

https://www.raspberrypi.org/forums/viewtopic.php?t=34061 presume, you have installed your selected OS on SD card. Boot sector of the SD card is normally accessible from Windows, so you can edit file config.txt. What you maybe need? Add into config.txt this line:

Code: Select all

hdmi_force_hotplug=1

well - how to edit this line !?

btw found some additonal texts:

Add these two lines to /boot/config.txt and reboot Raspbmc:

hdmi_force_hotplug=1 hdmi_drive=2

[Click and drag to move]

hdmi_force_hotplug=1 sets the Raspbmc to use HDMI mode even if no HDMI monitor is detected. hdmi_drive=2 sets the Raspbmc to normal HDMI mode (Sound will be sent if supported and enabled). Without this line, the Raspbmc would switch to DVI (with no audio) mode by default.

config.txt is read by the GPU so it will work on every distro.

There’s two ways to do it. In older Pi installs, use the fb0 framebuffer when you want to display stuff on the HDMI/TV display, for example: FRAMEBUFFER=/dev/fb0 startx will use the HDMI/TV framebuffer for X windows instead of the PiTFT

On Jessie Pi installs, run sudo nano /usr/share/X11/xorg.conf.d/99-fbdev.conf to edit the configuration file and make sure it contains: Copy Code

Section “Device” Identifier “display” Driver “fbdev” Option “fbdev” “/dev/fb0” EndSection

[Click and drag to move]

change the Option “fbdev” “/dev/fb0” line to Option “fbdev” “/dev/fb1” if you want the xdisplay on the PiTFT or fb1 to fb0 for HDMI output. Update: If don’t see the code above in the file, then simply copy and paste what is shown in this answer at the bottom of that file.If you can’t find 99-fbdev.conf file in that folder, then there is probably another file with different name like 10-evdev.conf inv the same folder which you will have to modify to make it work as described above.