Is there a openwrt/lede that works on the bpi r2 that I can download from a English website?

@frank-w “there should all necessary linked which is not os-specific”.

I would suggest that if you are going to mention the uboot console on the page then there needs to be a link to this other page (after all, how is the user going to know which page to review when reading the first page – not everybody is willing to examine multiple pages before finding the correct information – this seams to be the attitude from various governmental / public sector based organisations and is an inefficient usage of viewing instructions / corresponding pages).

Have added that link.

Btw. I’m a private person without any business relation to bpi-team. I’ve created the wiki in my freetime to share my personal experience and some of some other forum-users in a more usable way (structured) than here in the forum

1 Like

@frank-w, From another person that tries to help, support and educate other users with open source products and technologies, I do appreciate the issues surrounding producing good and well written documentation (especially by those of us who do this within our own free time). Therefore, I personally do appreciate when somebody else examines and critiques my documentation.

I have notice a real lack of input within this forum from both the bpi admin team and Sino-VoIP, and do recognise that you are spending a lot of time helping users of this forum. Again, it would be nice if either the admin team or members of Sino-VoIP would contribute more to this forum. As well as producing good documentation for their distro implementations. – I think you might have noticed a rant that I wrote within this forum a couple of week ago which criticised the admin team about this matter. Also, when reading comments from other forums about Sino-VoIP, it seams that this company has not truly encompassed the ideas of the open-source movement, as well as providing limited support for their products (which must be somewhat frustrating for yourself).

I am a long term supporter of the Nethserver project (URL provided below). NS does have a good forum in which the developers and the admin team does actually participate in. The NS staff actively encourages their users to support others (which sadly is lacking from this forum).

I personally have supported NS since April 2015, and whilst I provide limited direct help to the users, I do provide information about various projects, give suggestions and have just recently started writing articles about the history of the open-source movement, as well as written articles about usage of various technologies.

I am also a contributor to the social medium platform (a platform that is based on the ideals of the open-source movement, as well as encouraging free speech and open dialogue). This platform allows me and others to talk about new development, as well as to examine various political issues (both within the open-source movement and other aspects of modern life).

I tend to use as a testing ground for various articles. I also have released all my current articles on this platform (URL provided below). Also, I do contribute regularly to the user group and help / support groups.

I would love to contribute to this and other open-source based projects (but again, I am disappointed with the attitude of this forums admin staff).


I think we all experience the limited support from BPI team, but bringing it to their attention over and over probably will not change it either.

Then I most certainly don’t mean to be rude and I sincerely appreciate your very clearly formulated contributions, but you must forgive Frank for keeping his wiki and responses on this forum short and efficient, as he is currently almost, if not the only one that is keeping the community for this product alive. Instead I suggest you start writing some documentation yourself and we can work towards a properly supported and documented BSP together. All the help you can offer is very welcome, we all have our specialties!

1 Like

@BitMaster, Thanks for providing the information and it is a real shame that the BPI team (and Sino-VoIP) does not really want to support their user base or provide further support for their products (which is very telling of their business strategy). Whilst I do like Sino-VoIP products, this issue should be considered as a major criticism of their organisation and how they treat their customers.

Judging from the other threads within this forum, I do believe that Frank is doing his level best to support this community, if I can help and make some sort of difference, I will try and endeavour to help.

However, I will make this extremely serious point. The single board computer market is a very competitive market place and bad reputations could effect the future revenue of the developers of these boards. We are only starting to see a real uptake within this market and I personally don’t want to spend effort on projects that are going to fail due to deliberate complacency from the product developers / manufactures.

Saying that, due to the open-source ethos that is being portrayed by Sino-VoIP and BPI, I am willing to support this project for the moment but I do expect to see an improvement in the attitude of the BPI admin and dev teams (especially if they are intending to release new boards within a open-source based framework).

As said above, if I can help then I will try and support this community. Could Frank or yourself suggest any aspects that I could provide support for.

Also note, that due to my intention to setup a new business and my collaboration on other projects, I do have limited resources for any single project but again, will try and endeavour to support this community within reasonable expectations.

I’m now find where the problem is. Maybe that problem will not show up on you.

@frank-w, Ok, after extensive testing of various images, I wanted to install the openwrt for the BPI R2.

So after trying to write the image to a sd card (using the command: dd if=mtk-bpi-r2-SD.img of=/dev/sdc ), I examined the card with gparted.

The dd command stated that the image was written to the card – stating the following text:
136704+1 records in
136704+1 records out
69992452 bytes (70 MB) copied, 17.7135 s, 4.0 MB/s

However, when examining the card afterwards, gparted showed that the card had nothing written to it (and therefore displayed an unpartitioned medium)

Also tried to compile the image using your instructions (ref: ) using two separate environments (OpenSuse on an actual workstation and the latest Ubuntu version within a VM), both attempts failed during the compilation process.

These issues coupled with the problems of other images not being able to create fixed MAC addresses are wasting a lot of my time (and now are eating into my productivity time, which is costing me not only time but also actual money).

Could you please confirm that the images you supplied via your Google Drive account do actually work and provide any clues why the provided images do not successfully write to a SD card (note: I am not using any cheap cards but am actually using SanDisk approved medium)

As i said before,i have not tried them yet because of other things to do. But i assume that lede does not have a partition-table like standard-linux system because lede is for embedded systems and not for pc-systems. So lede does not need a partition table.

Try to boot it up…i confirm that i have only compiled last working source (last commits have problems)

@frank-w, Ok, seems a bit odd to me about lacking a partition table but I will try it. If there is no table, than I presume that the image can’t be resized once “burnt” on to the medium and therefore will only use use approximately 70MB (making the rest of the medium redundant)?

@frank-w, I am asking about partition tables not only because of the size requirements of the medium but also due to the possibility of including a swap partition and the extra need for squid / proxy caching.

@frank-w, I can confirm that the image does not work. After writing the image to the medium, placing the medium into the card interface / slot and then inserting the power jack, all three back (RGB) leds are activated, then after 5 seconds, the front three leds activate (blue for about 0.5 secs, followed by a single flash of the green and then the front red for 8 seconds), which is followed by a quick flash of the rj45 leds ( also during the cycling of the front led, the back green stayed on only to be switched off 1 second after the RJ45s flickered), finally followed by a static red led on the back.

Also just before the RJ45 lights, the screen (via hdmi) flickers a bright purple. I am guessing that this sequence is some form of POST procedure.

As stated above, after the sequence the back red stays powered and there is no further output via the hdmi or any other led.

Hdmi does not work in lede,purple screen is reported before. You can use deburg-uart for looking whats going on or you know the network-config. Leds are stable after boot…

i dont know if dhcp is actice on any port…you can try it and look in log of your router

Also, just to clarify, I have the R2 version1.2 model (this model lacks a lipo battery connector and is replaced with a SD / EMMC switch) – I have noticed that SinoVoIP has not provided the schematics to this particular version (with the exception of the switch and the lack of a second RVT capacitor on the rear of the device, it seems to be the same as the v1.1).

I have included a photo of this newer version of the board (apologies for the bad lighting and grainy image but I think you can clearly see the differences between this newer version and v1.1 – also ignore the heatsinks which have been added by myself).


@frank-w, Not using a router to connect with the board (I have a customised IPtable based firewall / network switch that is connected within my infrastructure and am only using fixed IP addressing – should be able to customised the IP address via the terminal). Also only the rear red led is stable after the post.

I will try the UART and report back.

@frank-w The UART did work. I noticed that the root partition is 1022.7m (just under a standard IEEE-1541 gigabyte) and the only NIC that has an IP is br-lan ( /24).

Question: on an un-configured openwrt does eth0 need a DHCP server?

Also there are only two logfiles within /var/log (which is a symlink to /tmp/log). lastlog and wtmp are empty (0 bytes)

Something that is concerning me is that according to ifconfig there is no wlan0. Do you know if the WiFi chipset works with this distro (I have a need to create an access point and bridge it with the 4 port network switch)?

One finial point, I have noticed that lan0 - lan3 shares the same MAC address as eth0 and not eth1 as would be expected.


Eth0 should be the ethernet-lane between mt7623 (soc) and mt7530 (switch). So here you need no ip-configuration. Maybe your wan-port must be adapted to your local net (if not 192.168.1.x).

But i have no experience in lede…i only compiled and uploaded it. Maybe you can add a partition table to use the other space to your card. I assume that the first 70mb contains a filesystem that is unpacked to a ramdisk. Your partitiontable have to start after the first 70mb (better more)

1 Like

I am also concerned about the randomised MAC addressing (as shown by other distributions). Does this effect this distro in the same way?