How to use BPI-4G LTE module with BPI-R2


(Prakash) #21

I have already done it. My log had,

send (AT+CGDCONT=1,“IP”,“www”,0,0^M) expect (OK) ^M ^M OK – got it


(Prakash) #22

I also tried with wvdial and my log is as follows,

Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,"IP", "www"
AT+CGDCONT=1,"IP", "www"
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
CONNECT 150000000
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Thu Apr  5 20:46:16 2018
--> Pid of pppd: 1893
--> Using interface ppp0
--> pppd: ��[02]
--> pppd: ��[02]
--> pppd: ��[02]
--> pppd: ��[02]
--> pppd: ��[02]
--> pppd: ��[02]
--> Disconnecting at Thu Apr  5 20:46:16 2018
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 320 seconds
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,"IP", "www"
AT+CGDCONT=1,"IP", "www"
OK
--> Modem initialized.

@Jackzeng Can you please share your 4.14.32 kernel?.

TIA.


(Prakash) #23

Hi. I was able to get the IP address for ppp0. My ifconfig shows as follows,

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:312 (312.0 B)  TX bytes:312 (312.0 B)

ppp0      Link encap:Point-to-Point Protocol  
          inet addr:10.108.210.40  P-t-P:10.64.64.64  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:52 (52.0 B)  TX bytes:58 (58.0 B)

However, the internet is not working. But I can ensure that the 4G SIM is connect the internet on mobile. My ppp1.sh log is as follows,

 sudo ./ppp1.sh &
[1] 2447
pi@bpi-iot-ros-ai:~$ quectel-pppd options in effect:
devname   /dev/ttyUSB2    # (default)
apn       www    # (default)
user         # (default)
password     # (default)
pppd options in effect:
debug           # (from command line)
nodetach                # (from command line)
dump            # (from command line)
noauth          # (from command line)
user            # (from command line)
password ??????         # (from command line)
/dev/ttyUSB2            # (from command line)
115200          # (from command line)
lock            # (from command line)
connect ''chat -s -v ABORT BUSY ABORT \"NO CARRIER\" ABORT \"NO DIALTONE\" ABORT ERROR ABORT \"NO ANSWER\" TIMEOUT 30 \"\" AT OK ATE0 O
K ATI\\;+CSUB\\;+CSQ\\;+CPIN?\\;+COPS?\\;+CGREG?\\;\\&D2 OK AT+CGDCONT=1,\\\"IP\\\",\\\"www\\\",,0,0 OK ATD*99# CONNECT'
                # (from command line)
disconnect chat -s -v ABORT ERROR ABORT \"NO DIALTONE\" SAY \"\\nSending break to the modem\\n\" \"\" +++ \"\" +++ \"\" +++ SAY \"\\nGo
od bay\\n\"             # (from command line)
nocrtscts               # (from command line)
modem           # (from command line)
asyncmap 0              # (from /etc/ppp/options)
lcp-echo-failure 4              # (from /etc/ppp/options)
lcp-echo-interval 30            # (from /etc/ppp/options)
hide-password           # (from /etc/ppp/options)
novj            # (from command line)
novjccomp               # (from command line)
ipcp-accept-local               # (from command line)
ipcp-accept-remote              # (from command line)
noipdefault             # (from command line)
ipcp-max-configure 30           # (from command line)
defaultroute            # (from command line)
usepeerdns              # (from command line)
noccp           # (from command line)
noipx           # (from /etc/ppp/options)
abort on (BUSY)
abort on (NO CARRIER)
abort on (NO DIALTONE)
abort on (ERROR)
abort on (NO ANSWER)
timeout set to 30 seconds
send (AT^M)
expect (OK)
^M
OK
 -- got it

send (ATE0^M)
expect (OK)
^M
^M
+CMTI: "ME",0^M
^M
+CMTI: "ME",1^M
^M
+CMTI: "ME",2^M
^M
OK
 -- got it

send (ATI;+CSUB;+CSQ;+CPIN?;+COPS?;+CGREG?;&D2^M)
expect (OK)
^M
^M
Quectel^M
EC25^M
Revision: EC25EFAR02A08M4G^M
^M
SubEdition: V04^M
^M
+CSQ: 23,99^M
^M
+CPIN: READY^M
^M
+COPS: 0,0,"Vodafone IN Vodafone IN",7^M
^M
+CGREG: 0,1^M
^M
OK
 -- got it

send (AT+CGDCONT=1,"IP","www",,0,0^M)
expect (OK)
^M
^M
OK
 -- got it

send (ATD*99#^M)
expect (CONNECT)
^M
^M
CONNECT
 -- got it

Script ''chat -s -v ABORT BUSY ABORT "NO CARRIER" ABORT "NO DIALTONE" ABORT ERROR ABORT "NO ANSWER" TIMEOUT 30 "" AT OK ATE0 OK ATI\;+C
SUB\;+CSQ\;+CPIN?\;+COPS?\;+CGREG?\;\&D2 OK AT+CGDCONT=1,\"IP\",\"www\",,0,0 OK ATD*99# CONNECT'' finished (pid 2453), status = 0x0
Serial connection established.
using channel 2
Using interface ppp0
Connect: ppp0 <--> /dev/ttyUSB2
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xfdd89f37> <pcomp> <accomp>]
rcvd [LCP ConfReq id=0x2 <asyncmap 0x0> <auth chap MD5> <magic 0xd962f060> <pcomp> <accomp>]
sent [LCP ConfAck id=0x2 <asyncmap 0x0> <auth chap MD5> <magic 0xd962f060> <pcomp> <accomp>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xfdd89f37> <pcomp> <accomp>]
sent [LCP EchoReq id=0x0 magic=0xfdd89f37]
rcvd [LCP DiscReq id=0x3 magic=0xd962f060]
rcvd [CHAP Challenge id=0x1 <b4481cf07b7c3a7bdedfb133e93586ad>, name = "UMTS_CHAP_SRVR"]
No CHAP secret found for authenticating us to UMTS_CHAP_SRVR
sent [CHAP Response id=0x1 <ab661aa85ab7984c2152e1083c6e5026>, name = ""]
rcvd [LCP EchoRep id=0x0 magic=0xd962f060 fd d8 9f 37]
rcvd [CHAP Success id=0x1 ""]
CHAP authentication succeeded
CHAP authentication succeeded
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
rcvd [IPCP ConfReq id=0x2]
sent [IPCP ConfNak id=0x2 <addr 0.0.0.0>]
rcvd [IPCP ConfNak id=0x1 <addr 10.108.210.40> <ms-dns1 10.174.30.245> <ms-dns2 10.174.30.244>]
sent [IPCP ConfReq id=0x2 <addr 10.108.210.40> <ms-dns1 10.174.30.245> <ms-dns2 10.174.30.244>]
rcvd [IPCP ConfReq id=0x3]
sent [IPCP ConfAck id=0x3]
rcvd [IPCP ConfAck id=0x2 <addr 10.108.210.40> <ms-dns1 10.174.30.245> <ms-dns2 10.174.30.244>]
Could not determine remote IP address: defaulting to 10.64.64.64
not replacing default route to eth0 [0.0.0.0]
local  IP address 10.108.210.40
remote IP address 10.64.64.64
primary   DNS address 10.174.30.245
secondary DNS address 10.174.30.244
Script /etc/ppp/ip-up started (pid 2467)
Script /etc/ppp/ip-up finished (pid 2467), status = 0x0

NOTE : I also tried other 4G SIM for testing. Same issue, no internet.


(Prakash) #24

Any inputs for my above issue?. TIA.


(Wolfgang) #25

Have you tried using QMI and the wwan0 interface instead? You will be getting better performance with QMI vs. PPP.


(Prakash) #26

@wtolkien I am not clear about the qmi steps. But I tried the following.

  • Installed libqmi
  • Create a new file at /etc/qmi-network.conf manually and added APN=www
# qmi-network /dev/cdc-wdm0 start
Loading profile at /etc/qmi-network.conf...
    APN: www
    APN user: unset
    APN password: unset
    qmi-proxy: no
Checking data format with 'qmicli -d /dev/cdc-wdm0 --wda-get-data-format '...
qmicli: symbol lookup error: qmicli: undefined symbol: qmi_device_close_async
Device link layer protocol retrieved: raw-ip
Getting expected data format with 'qmicli -d /dev/cdc-wdm0 --get-expected-data-format'...
error: cannot get expected data format: Expected data format not retrieved properly: Failed to open file '/sys/class/net/wwan0/qmi/raw_
ip': No such file or directory
Expected link layer protocol not retrieved: kernel unsupported
Updating device link layer protocol with 'qmicli -d /dev/cdc-wdm0 --wda-set-data-format=802-3 '...
qmicli: symbol lookup error: qmicli: undefined symbol: qmi_device_close_async
New device link layer protocol retrieved: raw-ip
Starting network with 'qmicli -d /dev/cdc-wdm0 --wds-start-network=apn='www'  --client-no-release-cid '...
qmicli: symbol lookup error: qmicli: undefined symbol: qmi_device_close_async
Saving state at /tmp/qmi-network-state-cdc-wdm0... (CID: 19)
Saving state at /tmp/qmi-network-state-cdc-wdm0... (PDH: 2274786176)
Network started successfully
  • ifconfig not showing anything of wwan0. I dont know how to up wwan0.
  • I am always getting this error,

qmicli: symbol lookup error: qmicli: undefined symbol: qmi_device_close_async

  • I am not finding this file as well, /sys/class/net/wwan0/qmi/raw_ip. I am using @Jackzeng latest Ubuntu 16.04 v1.3 2018-3-30 with kernel 4.4.70

Any kind of clear steps appreciated.


(ZB) #27

Hello,Did you see quectel-CM in root home path?

enter into it,and execute ./quectel-CM &

then,execute “dhclient wwan0”


(ZB) #28

if ppp get IP,but couldn’t connect Internet,did you check the dns?


(Prakash) #29

@Jackzeng I entered into quectel-CM folder, make the folder and then execute,

#./quectel-CM &

#dhclient wwan0

Its still NOT working now. I misunderstand that the internet connectivity was working by wwan0. But it was done by wifi wlan0; Not wwan0. Once I down the wlan0, internet connectivity is not working. May I know how can I check the DNS settings.
Thanks for all your guidance.


(Frank W.) #30

can you ping a public ip (e.g. 8.8.8.8)?


(Prakash) #31

@frank-w

> root@bpi-iot-ros-ai:~# ping 8.8.8.8
> connect: Network is unreachable

(ZB) #32

Hello,Neither ppp nor wwan can connect internet?

Could you try these steps again? Don’t connect other network interface on R2,just use 4G module,reboot R2,and up wwan0,let’s see will it connect the Internet.


(Prakash) #33

@Jackzeng Ok, as per your advise, I have done the following.

  • I disconnected wlan0
  • Then executed quectel-CM
root@bpi-iot-ros-ai:~/quectel-CM# ./quectel-CM &
[1] 2093
root@bpi-iot-ros-ai:~/quectel-CM# [04-09_14:27:27:133] WCDMA&LTE_QConnectManager_Linux&Android_V1.1.34
[04-09_14:27:27:134] ./quectel-CM profile[1] = (null)/(null)/(null)/0, pincode = (null)
[04-09_14:27:27:135] Find /sys/bus/usb/devices/3-1 idVendor=2c7c idProduct=0125
[04-09_14:27:27:136] Find /sys/bus/usb/devices/3-1:1.4/net/wwan0
[04-09_14:27:27:136] Find usbnet_adapter = wwan0
[04-09_14:27:27:136] Find /sys/bus/usb/devices/3-1:1.4/usbmisc/cdc-wdm0
[04-09_14:27:27:136] Find qmichannel = /dev/cdc-wdm0
[04-09_14:27:27:177] cdc_wdm_fd = 7
[04-09_14:27:27:252] Get clientWDS = 19
[04-09_14:27:27:285] Get clientDMS = 1
[04-09_14:27:27:317] Get clientNAS = 3
[04-09_14:27:27:349] Get clientUIM = 1
[04-09_14:27:27:382] Get clientWDA = 1
[04-09_14:27:27:412] requestBaseBandVersion EC25EFAR02A08M4G
[04-09_14:27:27:509] requestGetSIMStatus SIMStatus: SIM_READY
[04-09_14:27:27:541] requestGetProfile[1] www///0
[04-09_14:27:27:573] requestRegistrationState2 MCC: 404, MNC: 84, PS: Attached, DataCap: LTE
[04-09_14:27:27:604] requestQueryDataCall IPv4ConnectionStatus: DISCONNECTED
[04-09_14:27:27:669] requestRegistrationState2 MCC: 404, MNC: 84, PS: Attached, DataCap: LTE
[04-09_14:27:27:701] requestSetupDataCall WdsConnectionIPv4Handle: 0x871f1eb0
[04-09_14:27:27:764] requestQueryDataCall IPv4ConnectionStatus: CONNECTED
[04-09_14:27:27:797] ifconfig wwan0 up
[04-09_14:27:27:807] Fail to access /usr/share/udhcpc/default.script, errno: 2 (No such file or directory)
[04-09_14:27:27:807] busybox udhcpc -f -n -q -t 5 -i wwan0
[04-09_14:27:27:858] udhcpc (v1.22.1) started
[04-09_14:27:27:891] Sending discover...
[04-09_14:27:27:952] Sending select for 10.111.114.53...
[04-09_14:27:28:021] Lease of 10.111.114.53 obtained, lease time 7200 
  • Then executed dhclient wwan0
root@bpi-iot-ros-ai:~/quectel-CM# ifconfig
docker0   Link encap:Ethernet  HWaddr 02:42:eb:c0:ff:c8  
          inet addr:172.17.0.1  Bcast:0.0.0.0  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0      Link encap:Ethernet  HWaddr aa:9f:19:b4:e6:d5  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:97 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:17396 (17.3 KB)
          Interrupt:71 

eth1      Link encap:Ethernet  HWaddr 92:2d:a2:e2:5f:a4  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:99 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:17836 (17.8 KB)
          Interrupt:71 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:241 errors:0 dropped:0 overruns:0 frame:0
          TX packets:241 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:19165 (19.1 KB)  TX bytes:19165 (19.1 KB)

wlan0     Link encap:Ethernet  HWaddr 00:08:22:b0:b8:fb  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wwan0     Link encap:Ethernet  HWaddr 8e:9a:7e:02:94:54  
          inet addr:10.111.114.53  Bcast:10.111.114.55  Mask:255.255.255.252
          inet6 addr: fe80::8c9a:7eff:fe02:9454/64 Scope:Link
          UP BROADCAST RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:7 errors:0 dropped:0 overruns:0 frame:0
          TX packets:36 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1797 (1.7 KB)  TX bytes:5837 (5.8 KB)
> root@bpi-iot-ros-ai:~/quectel-CM# ping 8.8.8.8
> PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
> ^C
> --- 8.8.8.8 ping statistics ---
> 43 packets transmitted, 0 received, 100% packet loss, time 71148ms
> 
> root@bpi-iot-ros-ai:~/quectel-CM# ping google.com
> PING google.com (172.217.161.14) 56(84) bytes of data.
> ^C
> --- google.com ping statistics ---
> 7 packets transmitted, 0 received, 100% packet loss, time 6007ms

I confirmed that the SIM working fine with 4G internet on mobile phones along with same APN. TIA.


(ZB) #34

hello,that’s strange,could you try this command “./quectel-CM -s www &”.

my logs are 99% similar with yours,I will try to find the reason.

here are my logs,you can compare it:

./quectel-CM &

root@bpi-iot-ros-ai:~/quectel-CM# ./quectel-CM &
[1] 2471
root@bpi-iot-ros-ai:~/quectel-CM# [04-09_15:13:25:306] WCDMA&LTE_QConnectManager_Linux&Android_V1.1.34
[04-09_15:13:25:308] ./quectel-CM profile[1] = (null)/(null)/(null)/0, pincode = (null)
[04-09_15:13:25:310] Find /sys/bus/usb/devices/3-1 idVendor=2c7c idProduct=0125
[04-09_15:13:25:311] Find /sys/bus/usb/devices/3-1:1.4/net/wwan0
[04-09_15:13:25:311] Find usbnet_adapter = wwan0
[04-09_15:13:25:312] Find /sys/bus/usb/devices/3-1:1.4/usbmisc/cdc-wdm0
[04-09_15:13:25:312] Find qmichannel = /dev/cdc-wdm0
[04-09_15:13:25:345] cdc_wdm_fd = 7
[04-09_15:13:25:433] Get clientWDS = 19
[04-09_15:13:25:467] Get clientDMS = 1
[04-09_15:13:25:499] Get clientNAS = 3
[04-09_15:13:25:530] Get clientUIM = 1
[04-09_15:13:25:562] Get clientWDA = 1
[04-09_15:13:25:595] requestBaseBandVersion EC25EFAR02A08M4G
[04-09_15:13:25:690] requestGetSIMStatus SIMStatus: SIM_READY
[04-09_15:13:25:723] requestGetProfile[1] 3gnet///0
[04-09_15:13:25:755] requestRegistrationState2 MCC: 460, MNC: 11, PS: Attached, DataCap: LTE
[04-09_15:13:25:787] requestQueryDataCall IPv4ConnectionStatus: DISCONNECTED
[04-09_15:13:25:851] requestRegistrationState2 MCC: 460, MNC: 11, PS: Attached, DataCap: LTE
[04-09_15:13:25:915] requestSetupDataCall WdsConnectionIPv4Handle: 0x871ffba0
[04-09_15:13:25:978] requestQueryDataCall IPv4ConnectionStatus: CONNECTED
[04-09_15:13:26:010] ifconfig wwan0 up
[04-09_15:13:26:038] Fail to access /usr/share/udhcpc/default.script, errno: 2 (No such file or directory)
[04-09_15:13:26:039] busybox udhcpc -f -n -q -t 5 -i wwan0 
[04-09_15:13:26:093] udhcpc (v1.22.1) started
[04-09_15:13:26:130] Sending discover...
[04-09_15:13:26:210] Sending select for 10.71.84.99...
[04-09_15:13:26:270] Lease of 10.71.84.99 obtained, lease time 7200

ifconfig

root@bpi-iot-ros-ai:~/quectel-CM# ifconfig
docker0   Link encap:Ethernet  HWaddr 02:42:97:ef:b9:73  
      inet addr:172.17.0.1  Bcast:0.0.0.0  Mask:255.255.0.0
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0      Link encap:Ethernet  HWaddr 52:bd:74:2d:93:93  
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:115 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:23048 (23.0 KB)
      Interrupt:71 

eth1      Link encap:Ethernet  HWaddr ca:4b:0f:11:e1:1d  
      inet addr:192.168.30.130  Bcast:192.168.30.255  Mask:255.255.255.0
      inet6 addr: fe80::e46:b9a5:25e4:bbf5/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:178 errors:0 dropped:0 overruns:0 frame:0
      TX packets:472 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:44388 (44.3 KB)  TX bytes:44006 (44.0 KB)
      Interrupt:71 

lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:533 errors:0 dropped:0 overruns:0 frame:0
      TX packets:533 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1 
      RX bytes:42643 (42.6 KB)  TX bytes:42643 (42.6 KB)

wlan0     Link encap:Ethernet  HWaddr 00:08:22:d0:bb:fb  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wwan0     Link encap:Ethernet  HWaddr 92:73:5f:a8:1d:9c  
      inet addr:10.71.84.99  Bcast:10.71.84.103  Mask:255.255.255.248
      inet6 addr: fe80::9073:5fff:fea8:1d9c/64 Scope:Link
      UP BROADCAST RUNNING NOARP MULTICAST  MTU:1500  Metric:1
      RX packets:31 errors:0 dropped:0 overruns:0 frame:0
      TX packets:93 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:3106 (3.1 KB)  TX bytes:11418 (11.4 KB)

root@bpi-iot-ros-ai:~/quectel-CM# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=43 time=130 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=43 time=48.0 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=43 time=46.0 ms

(ZB) #35

I have a question,where do you have this test, in Australia?

I need to make sure the 4G module(EC25-E) will support this area.

EC25-E support: EMEA/Thailand/India/South Korea

EC25-AU support: Australia

EC25-V support:North America


(Prakash) #36

Hi. I am testing from India. Using Vodafone 4G SIM. Also like to know if any anyone already tried this module in India. I strongly believe that there are some configuration issues rather than 4G hardware, driver or APN. Because I tried with few other 4G SIMs. All are giving the same result.


(ZB) #37

maybe route configuration is not right,could you show your route log?


(Prakash) #38

Ok, my netstat & route shows as below.

root@bpi-iot-ros-ai:~/quectel-CM# netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         100.114.230.33  0.0.0.0         UG        0 0          0 wwan0
100.114.230.0   0.0.0.0         255.255.255.192 U         0 0          0 wwan0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 docker0
172.17.0.0      0.0.0.0         255.255.0.0     U         0 0          0 docker0

root@bpi-iot-ros-ai:~/quectel-CM# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         100.114.230.33  0.0.0.0         UG    0      0        0 wwan0
100.114.230.0   *               255.255.255.192 U     0      0        0 wwan0
link-local      *               255.255.0.0     U     1000   0        0 docker0
172.17.0.0      *               255.255.0.0     U     0      0        0 docker0

(Wolfgang) #39

When you pinged google.com, the domain name correctly resolved to 172.217.161.14. To me this indicates that you have working 2-way communication, at least as far as DNS is concerned. Can you run tcpdump on wwan0? Maybe this will give some further information.

I don’t think this is an issue of using the -E/-AU/-V version of the EC25. The difference is usually in the LTE bands that are supported. Since you get a connection, your EC25 finds at least one suitable band.


(Frank W.) #40

since dns seems to work (maybe do a “dig www.google.com” to find out how this is done…maybe a local cached dns) a traceroute/tcpdump will be the next step

with ping 8.8.8.8 i want to see if it is a dns-issue or the basic ip-connection is affected