Help for testing 4.19 on R2


(Frank W.) #1

Hi,

i’ve merged 4.19-main and hdmi+gmac into 4.19-testing for having 1 4.19-kernel with all features currently working in 4.19.

  • poweroff
  • internal wifi
  • hdmi+fbdev (needs video=1920x1080 in cmdline or any other resolution)
  • second gmac (wan connected to eth1 like in 4.14)

have uploaded binary-package here

https://drive.google.com/open?id=1MY8owoBdyv060u0QcE0GVC1YEtIPgu5E

hope there will some people for testing

hdmi works with the following resolutions:

  • 1280x1024 (hdmi2dvi) xserver+fbdev
  • 1080p xserver+fbdev

2nd gmac:

root@bpi-r2:~# ip a                                                             
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group defau0
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00                       
    inet 127.0.0.1/8 scope host lo                                              
       valid_lft forever preferred_lft forever                                  
    inet6 ::1/128 scope host                                                    
       valid_lft forever preferred_lft forever                                  
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP g0
    link/ether 86:0d:62:b7:de:c7 brd ff:ff:ff:ff:ff:ff                          
    inet6 fe80::840d:62ff:feb7:dec7/64 scope link                               
       valid_lft forever preferred_lft forever                                  
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP g0
    link/ether 92:df:b5:57:69:99 brd ff:ff:ff:ff:ff:ff                          
    inet6 fe80::90df:b5ff:fe57:6999/64 scope link                               
       valid_lft forever preferred_lft forever                                  
4: sit0@NONE: <NOARP> mtu 1480 qdisc noop state DOWN group default qlen 1000    
    link/sit 0.0.0.0 brd 0.0.0.0                                                
5: wan@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP 0
    link/ether 92:df:b5:57:69:99 brd ff:ff:ff:ff:ff:ff                          
    inet 192.168.0.42/24 brd 192.168.0.255 scope global wan                     
       valid_lft forever preferred_lft forever                                  
    inet6 fe80::90df:b5ff:fe57:6999/64 scope link                               
       valid_lft forever preferred_lft forever                                  
6: lan0@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state 0
    link/ether 86:0d:62:b7:de:c7 brd ff:ff:ff:ff:ff:ff                          
    inet 192.168.4.10/24 brd 192.168.4.255 scope global lan0                    
       valid_lft forever preferred_lft forever                                  
7: lan1@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master0
    link/ether 86:0d:62:b7:de:c7 brd ff:ff:ff:ff:ff:ff                          
8: lan2@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master0
    link/ether 86:0d:62:b7:de:c7 brd ff:ff:ff:ff:ff:ff                          
9: lan3@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state 0
    link/ether 86:0d:62:b7:de:c7 brd ff:ff:ff:ff:ff:ff                          
10: br0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN 0
    link/ether 86:0d:62:b7:de:c7 brd ff:ff:ff:ff:ff:ff                          
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br0                      
       valid_lft forever preferred_lft forever                                  
11: lan3.60@lan3: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue st0
    link/ether 86:0d:62:b7:de:c7 brd ff:ff:ff:ff:ff:ff                          
    inet 192.168.60.10/24 brd 192.168.60.255 scope global lan3.60               
       valid_lft forever preferred_lft forever                    

ping over wan (eth1):

--- 192.168.0.10 ping statistics ---                                            
1026 packets transmitted, 1026 received, 0% packet loss, time 1066036ms         
rtt min/avg/max/mdev = 0.339/0.426/0.560/0.040 ms 

ping over lan0 (eth0):

--- 192.168.0.10 ping statistics ---                                            
1634 packets transmitted, 1634 received, 0% packet loss, time 1698243ms         
rtt min/avg/max/mdev = 0.336/0.428/0.798/0.035 ms          

wifi-ap (connection from my cellphone, did ssh to r2 wifi-interface):

ap0: Event ASSOC (0) received                                                   
ap0: STA b4:9d:xx:xx:22:e9 IEEE 802.11: associated                              
STA did not include WPS/RSN/WPA IE in (Re)AssocReq                              
  New STA                                                                       
ap_sta_add: register ap_handle_timer timeout for b4:9d:xx:xx:22:e9 (300 seconds 
- ap_max_inactivity)                                                            
nl80211: Set STA flags - ifname=ap0 addr=b4:9d:xx:xx:22:e9 total_flags=0x0 flags
_or=0x0 flags_and=0xfffffff1 authorized=0                                       
ap0: AP-STA-CONNECTED b4:9d:xx:xx:22:e9                                         
ap0: STA b4:9d:xx:xx:22:e9 RADIUS: starting accounting session 5BFAC73E-00000000
IEEE 802.1X: Ignore STA - 802.1X not enabled or forced for WPS                  
hostapd_new_assoc_sta: reschedule ap_handle_timer timeout for b4:9d:xx:xx:22:e9 
(300 seconds - ap_max_inactivity)                                               
nl80211: Event message available                                                
nl80211: Drv Event 20 (NL80211_CMD_DEL_STATION) received for ap0                
nl80211: Delete station b4:9d:xx:xx:22:e9                                       
ap0: Event DISASSOC (1) received                                                
ap0: STA b4:9d:xx:xx:22:e9 IEEE 802.11: disassociated                           
ap0: AP-STA-DISCONNECTED b4:9d:xx:xx:22:e9                                      
nl80211: sta_remove -> DEL_STATION ap0 b4:9d:xx:xx:22:e9 --> 0 (Success)        
ap_free_sta: cancel ap_handle_timer for b4:9d:xx:xx:22:e9

regards Frank


(Alex R.) #2

I’ve installed new kernel. HDMI/Wi-Fi/USB/SATA - Everything is ok. I see both eth0 and eth1 devices but can’t test in right now (wifi-onsy setup).

I’ve also modified udev rules to set different MACs on eth0 and eth1.

ACTION=="add", SUBSYSTEM=="net", KERNELS=="eth0", RUN+="/bin/ip link set dev %k address ae:fc:de:ad:be:ee"
ACTION=="add", SUBSYSTEM=="net", KERNELS=="eth1", RUN+="/bin/ip link set dev %k address ae:fc:de:ad:be:ef"

1b100000.ethernet eth0
didnt worked for me so i left only eth0/1.


(Alex R.) #3

I’ve testet wan/lan. Looks Ok for me. Also I’ve found that udev rulres doesn’t affect on wan/lan intercaces mac addresses. Tese interfaces have the macs that generates random on boot.

My example:

3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether ae:fc:de:ad:be:ef brd ff:ff:ff:ff:ff:ff
    inet6 fe80::acfc:deff:fead:beef/64 scope link
       valid_lft forever preferred_lft forever
..
5: wan@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether ba:0d:31:83:39:fe brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global wan
       valid_lft forever preferred_lft forever
    inet6 fe80::b80d:31ff:fe83:39fe/64 scope link
       valid_lft forever preferred_lft forever

and

[ 4.766387] mtk_soc_eth 1b100000.ethernet: generated random MAC address ba:0d:31:83:39:fe


(Frank W.) #4

lan/wan gets (random) mac from cpu-port. Imho your udev is later…why it works for eth i don’t know.i guess it is because interface needs to be down for mac-setting.

I set mac via network/interfaces…preup


(Frank W.) #5

had forgotten change to mdio-device in testing-branch…updated now…currently uploading