[Error while booting] sunxi_ss_alg_register()681 - crypto_register_ahash(md5) failed! return -22


(BananasHavePotassium) #1

Hi my BananaPi M2 Ultra with Ubuntu Mate installed stopped working after power off

It stucks on:

sunxi_ss_alg_register()681 - crypto_register_ahash(md5) failed! return -22 
sunxi_ss_probe()793 - sunxi_ss_alg_register() failed! return -22 

I’m desperated now I’d like to wipe emmc to reinstall OS since I don’t know what to do. I can’t boot it from sd card which is what I wanted in order to rease emmc.

Any solutions are welcome. Please help


[Solved] How to flash emmc?
(ZB) #2

It seems that your image was damaged? could you provide your log? and which image did you use?


(BananasHavePotassium) #3

That is Ubuntu Mate 16.04 - not sure which image now. The thing is that it worked for a few days. I’ve installed and configured apache, owncloud, set up automount for SATA disk. I also did sudo apt-get update and sudo apt-get upgrade.

It broke after a power off

I don’t know how to gather logs (maybe I’ll take a photo when I’m back home). The device is connected via HDMI to my tv. I rewrote what I saw on my tv screen