BPI-R2 new image : ubuntu 16.04 V1.2.1 BT and WIFI AP mode are working fine 2017-11-27


(Frank W.) #21

which chipset of usb2serial, which application do you use with which settings?

please format your output with code-button (</>)


(Kenn Dyrvig) #22

Hi Frank

i use ftdi baudrate 115200 8n1 i use putty on windows 10 and i get if i press any key on my keyboard it starts to send more i have tryed with backspace but dosent work do i have to use console under linux

In: serial Out: serial Err: serial Net: Eth0 Uip activated Hit any key to stop autoboot: 0 BPI-R2> BPI-R2> BPI-R2> BPI-R2> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-BoPreformatted text


(Kenn Dyrvig) #23

In: serial Out: serial Err: serial Net: Eth0 Uip activated Hit any key to stop autoboot: 0 BPI-R2> BPI-R2> BPI-R2> BPI-R2> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-Boot 2014.04-rc1 (Sep 05 23>>>> U-BoPreformatted text


(Frank W.) #24

select your output from serial console and press the </>-button…you can also edit your posts

which chipset? there are known problems with profilic-chips


(Kenn Dyrvig) #25

probaly profilic and i dosent matter if i press </> it still looks like in previus post


(Kenn Dyrvig) #26

the lede image is 907 maby i have the vrong one


(Kenn Dyrvig) #27

Maby i have connected it wrong on the db9 plug


(Frank W.) #28

db9? an old COM-Port? attention, this may have 12V!


(Kenn Dyrvig) #29

it is a usb to db9 serial adapter


(Frank W.) #30

can you turn off flow-control in putty?


(Kenn Dyrvig) #31

hi Frank

yes i have tryed that also


(Frank W.) #32

your usb2serial has clean state in device-manager?? ok, else you should got nothing…i needed some time to get working driver for my cp2102, but now it works as expected

bpi-r2-serial.reg (14,2 KB)

you have to change com-port to yours


Using Debug UART
(Kenn Dyrvig) #33

hi Frank

but how did you get to the uboot promt so run the emmc pconf 48

kenn


(Frank W.) #34

is it now working?

on booting you see the uboot-menu in debug-uart:

here you can see it: http://www.fw-web.de/dokuwiki/doku.php?id=en:bpi-r2:uboot

there take the last menu-item “U-Boot console”


(Kenn Dyrvig) #35

Hi Frank

How do you make the uboot image to put on the sd card do you have a image or

kenn


(Frank W.) #36

why not scrolling that wiki-page a bit down to #update_uboot :slight_smile:

you find compiled actual uboot (with emmc) on my gdrive: https://drive.google.com/drive/folders/15Y5Y3NAOwg_IMmN3k6hdb7pAQj9oTVTl


(Kenn Dyrvig) #37

Hi frank

i can see the uboot menu in my console but hov do you stop it from continuing booting from sd it goes past fast and i can only find it by scrolling back


(Frank W.) #38

pressing any key (e.g. cursor down to move inside menu) while it is displayed (for about ~3 seconds)

connect first uart and than boot…or reboot after connecting uart if system already running


(Kenn Dyrvig) #39

Hi Frank

still no luck i have ordred the cp2102 hope that helps it still just boots no matter what key i press i have installed the reg key with my com port but no luck is it not possibel to make a uboot image that boots strait into uboot promt seems very dificult to use that emmc

kenn


(Frank W.) #40

back to Bluetooth…does anybody got a working connection? which tools are used which commands. please post log of init and connection.