BPI-M3 compile Opencv 3.1.0 source code


(bpi team) #9

you can test this image at frist.

http://pan.baidu.com/s/1c1RdWQ0


(Zhiqing Yu) #10

hehe .this is from my shell .in test time ,#and \ do not need. emmc is my dir .


#11

C’mon: If you’re at ~/emmc and then do a

sudo git clone https://github.com/Itseez/opencv.git

Then now opencv is in

~/emmc/opencv

If you now do the following while still being in ~/emmc

sudo mkdir emmc/opencv/build
cd emmc/opencv/build

then opencv is still in ~/emmc/opencv but you created and changed into ~/emmc/emmc/opencv/build while you wanted to be at ~/emmc/opencv/build instead. There’s is one step missing (cd ..) or the occurences of emmc/ are too much.

I wrote exactly this two times already but it’s obviously absolutely useless since you don’t seem to take care of the difference between ~/emmc/emmc/opencv/build (wrong) and ~/emmc/opencv/build (right). The ‘instructions’ above simply can not work and that’s just one of the mistakes. And it’s always the same: As soon as @sinovoip posts instructions they’re partially wrong so exactly nobody can benefit from. So why do you waste your time providing useless instructions again and again?

Same here: [BPI-M3] how to use fatload uEnv.txt & script.bin & kernel uImage Still wrong: scrip=script.bin can NOT work! You’ve been told several times and you simply don’t give a sh*t. There’s still a t missing. You not even fix such simple mistakes. And this pretty much describes the entirety of the catastrophic state of documentation and the lousy support situation.


#12

CN6 / CSI connector not populated so you’re showing pictures made with an USB cam there as proof that BPi M3 works with a dual camera setup. Always fakes… :frowning:

I’ve never seen the proof that any of your boards really works with a CSI camera :slight_smile:


(Oguzhan Baser) #13

Make process gave error under ubuntu… :frowning:


(Zhiqing Yu) #14

this is for rasbian,Ubuntu and debian have many error


(Zhiqing Yu) #15

tkaiser @
at sudo mkdir emmc/opencv/build means emmc/opencv mkdir build

you can test it


(Oguzhan Baser) #16

if you have a time can you try to install ros with this link? because I sholud use opencv with ROS. My internet download speed is very slow I cant download rasbian now.

If install successful I will download rasbian it this night.


(Zhiqing Yu) #17

sorry my nearest work is opencv and uav .you can do it yourself


(Oguzhan Baser) #18

Hmm… thanks for your helps to contribute this topic. Lastly, I want to ask did you used opencl with your application. If yes, which application did you use and how many fps did you take? If you can answer I will be very happy … :slight_smile:


(bpi team) #19

are you test this Ros image ???


(Zhiqing Yu) #20

i have test this image but opencv unsucseece


(Oguzhan Baser) #21

@sinovoip I cannot test it because I don’ t have a download link. I m waiting Google Drive link.

@zhiqing_yu I tried rasbian image opencv succesfully installed just. But opencl device cannot find. I am trying to use optical flow lukas kanade algorithm. But banana pi is working 1 or 2 fps.


(Zhiqing Yu) #22

bpi m3 use Allwinner A83t SGX544 MP2 have 44.8 gflops

,opencl need trenclate cpu ram gpu ,at the time opencl have much eer .i sugest you use cpu only down pix up fps


#23

This is not true. A31/A31s used SGX544MP2, A83T contains only SGX544MP1 (half that fast) and you can’t use OpenCL ‘out of the box’ anyway. Just read through the forums of responsible vendors that used these GPUs in their SoCs to get the idea (TI or NXP for example).

Everthing that’s written in datasheets or marketing material regarding BPi M3 is either irrelevant or wrong :slight_smile:


(Zhiqing Yu) #24

http://bbs.meizu.cn/thread-5868029-1-1.html


#25

So you believe every BS you find somewhere on the web? GPU is wrong there, MHz are wrong, GFLOPS are wrong.

Look into the datasheet http://linux-sunxi.org/A83T#Documentation and look for Antutu 3D scores of A83T equipped devices. GPU clockspeed will be reduced brutally since A83T is always overheating:

Did you ever tried this out? Just do some GPU intensive stuff and watch dmesg output: GPU clock will be reduced even with mild workloads.


(Zhiqing Yu) #26

you r right.i make mistake


#27

No problem. I make mistakes all day long :slight_smile:

But that’s the problem with Banana Pi M3. A beefy product when looking at specs. But can you run it with all CPU cores busy at top speed? No. Does it matter whether GPU clock speed is specified above 600 MHz? No since everytime you would need the performance CPU cores get killed and/or throttle down and the same applies to the GPU (since it’s just one core with 4 shaders here only throttling applies since you can’t kill the only core).

The whole board is a design flaw. A HUGE heatsink is the most basic requirement for A83T! But since they do not test their stuff under normal conditions they do not even know (or did you ever see a single picture of any BPi M3 made by @sinovoip where A83T has a heatsink? They simply don’t care at all about performance)


(Vlad) #29

How to install opencv version 3 on the python3. This manual install opencv only with python2.7(