BPI-M2 Ultra/BPI-M2 Berry new image : Armbian Bionic and Stretch


(Yuri) #28

hello Igor. I have Banana PI M2U and Im using Armbian Bionic (desktop mainline kernel 4.19.y). My sound doesn’t work and I can’t configure it. Do you have any leads for me please ?

Thank you


(Ralf Rüssel) #29

hi i build an img from the trunk but i cant enable spidev i use the armbian-config to get access but under /dev/ didnt appear spidev0.0 after reboot. what can i do?


(Igor) #30

This feature is not developed and board is not supported. Everything that exists comes as is.

Perhaps cover some costs or https://www.armbian.com/get-involved ?


(Juan Sánchez) #31

hello @igorpec along with say hello, know if you can add the following patches to m2ultra:

https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/patch/?id=e5c6e693be831c1bba9b4f8f1da597fb5514deca

https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/patch/?id=a5a4bc14914faf219336d71c71595975b8112ff7

https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/patch/?id=26e9ffeb2c04f0f577d0179e7eca8e1d54f9e050

https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/patch/?id=5f9e882825467105acafd208520b69bf95adb963

https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/patch/?id=ca117b6528b9da81d83ac6ec51d7d456894690dc


(Igor) #32

The same reply as in previous post.


#33

Should be on it’s way. https://github.com/armbian/build/commit/c430a2ac3d316a4270493fdbb1afd63aaffddded


#34

Hallo, a new user here. Apparently the image Armbian_5.69_Bananapim2ultra_Debian_stretch_next_4.19.13.img does not boot (unlike Armbian_5.66_Bananapim2ultra_Debian_stretch_dev_4.18.18.img).

Jan


(Tim) #35

It boots except that the HDMI video driver not working. So no HDMI output. I just downloaded it for my bpi m2u and burned to a micro sd card. It worked, but hdmi not working. I am using serial port and seeing the serial console. But, like others, my wireless still not working both wi-fi and bluetooth. Help!

Tim


#36

Those wifi patches are on dev branch. Try building it using Armbian build system. I have built an image with debian stretch headless, you can try that. I haven’t tested it because I’m not at home.

https://drive.google.com/file/d/1AhlEm2jrNGFU-y7uZDIpUacAHgyvTgjG/view?usp=sharing

sha256 9ed836cb839606ab5bfc7c61e2a9148c10a82d2e418e333d998632ed8267cd5b Armbian_5.71_Bananapim2ultra_Debian_stretch_dev_4.20.2.img


(Tim) #37

Thank you so much, jero. Now it worked both HDMI and wifi. But the bluetooth still not working. Any chance to know what should I do to enable it?


#38

Don’t know, but BT+wifi are in the same module, so it should work. Check your BT configuration and if it doesn’t help, try asking on armbian P2P forum.


#39

I am new to “Bananas” but certainly not new to linux. I have to get my on TTL/USB cable to be able to see what’s going on…


(Tim) #40

Well, for that, I’d say you might have got a problematic image or SD card. I did download Armbian 5.66 and 5.69 images and they boot. Just no wireless. Jero provided/shared a link for Armbian 5.71. It worked for HDMI and Wifi. Take a look: https://drive.google.com/file/d/1AhlEm2jrNGFU-y7uZDIpUacAHgyvTgjG/view?usp=sharing

@jero: I saw another post. They made Broadcom bluetooth and mentioned AMPAK. I downloaded kernel source and found that in Broadcom driver those modules were not selected and comipled. Wondering the BT driver was not made in image. https://www.spinics.net/lists/linux-bluetooth/msg77626.html


(Igor) #41

HDMI seems to be broken when switching u-boot to 2018.11


#42

Hi!

I am newbie with Bpi M2U, the 5.69 armbian not booting, but 5.71 boot, and I can not turn on the spidev. I used the armbian-config. Any suggestion?

Thank you in advance for your answers.


(Igor) #43

Overlays for R40 are not developed so you can’t just turn them on. You have to fiddle manually with board DTB. No idea if SPI works.


(Mario Frost) #44

Hello, unfortunately i have no skills in programming and also my kowledge might be not huge enough to exactly understand why i have the problem with i2c, so i hope it is okay to ask here.

I tried to activate the I2C in armbian-config to get an oled, bmp sensor and others working. But i2cdetec will detect none of them - so i guess the activation don’t really work!? I also tried to figure it out with several toturials from the internet, where other were able to use i2c with a bananapi. Is my failure image related (maybe not implemented functions?) or am i the layer 8 problem and i’m ‘not to see the wood for the trees’?


(Igor) #45

It is perfectly O.K. if you don’t have the knowledge and if you asks. And I already gave you the answer. There is no support for manipulating HW functions on R40 in a simple manner. Why? Because nobody developed that. I am not 100% sure, but I think functions are supported by the kernel, but their manipulation is not brought up to the human readable levels. And there is no certainty this will ever be. Our resources are 100x too small to fix all those things …


#46

Don’t mix up a bananapi from “Hard Kernel” and a banana-pi from SinoVoIp !

If it’s just for playing with a BMP sensor and an OLed display, it’s better to use a ESP8266 with LUA language and Wifi for saving big datas on the cloud. It’s working fine and cheaper.


(Mario Frost) #47

Thanks for the answers. My intention was to bring my home-automation (FHEM and Nextcloud) into my 19" rack. For this adventure i chose this way: https://www.thingiverse.com/thing:2894571 My decision / choice was to use a BananaPi M2 BRY instead of a RaspberryPi 3B+, because i wanted to use the SATA port of the M2 BRY and take the read/write load from the SD card. For the RaspberryPi it’s very simple to active the I2C and connect the oled to show the parameters to monitor. All i wanted to do was to do the same on the M2 BRY, but it wasn’t clear to me that there is a problem with this. Are there other ways to realize this part of the project? regards Mario