BananaPi BPI-M2Z(H2+) New Image Raspbian & Ubuntu Release 2018-07-09


#16

Hi @Jackzeng ,

BPI Zero is auto rebooting after SD card cloning.

Stuck at vmouse_input_dev_close and goes to restart loop.

what may be the issue ?


(Cristiano Pimentel) #17

It don’t work. I burn the image then BPI M2 Zero boot up with some messages on screen (fast) and then blank screen. No video signal. Only if i reset the device, the same occur: Boot messages are show rapidly and blank screen and red led.

Only Armbian image works fine. Ubuntu and Raspbian not work!!! Only partial boot…

UPDATE: It don’t works at 1366x768 resolution of China’s LCD “TOP PC” series. I change it by a Dell Monitor and got HDMI video out with sucess! - But this forum has a poor support. I made a question and anyone could help me. The Raspbian image has some problems with wifi and audio too. Raspberry pi zero forum has a much batter support…


#18

Have loaded the Raspbian image and it works like a champ! But I couldn’t find a config.txt file or it’s equivalent - there is a reference in /boot/bananapi/bpi-m2z/linux:boot.cmd that parameter changes should be made to /boot/armbianEnv.txt however that file doesn’t exist either.

I’ve tried creating those files, using simple R-Pi configuration statements (e.g. “display_rotate=2”) to no avail, and can’t discern whether:

  • the system isn’t looking for a config file at all;
  • is looking, but for a different file name or at a different location;
  • finds the fie but expects different parameter names than those used by R-Pi

Any light you can you shed on configuration options and how they are instantiated would be appreciated!


(ZB) #19

Sorry for the late rely, For first question, May I know how did you compile the 8188eu driver, maybe it is the compile (environment or cpu types different) problem?

For second question, could you give more logs? vmouse is a virtual input device, the reason is not probably on this.

image

after vmouse_input_dev_close , it will mount filesystem, Will it be other questions?


(ZB) #20

Thanks for your advice, We will test more displays in the future.

what’s the problem with your wifi or audio?

you could use wifi by inputting commands on terminal, GUI could not support to operate wifi now.

here is the steps: http://wiki.banana-pi.org/Getting_Started_with_M2_Zero#WiFi_Client


(ZB) #21

Hello, M2Z use allwinner chips, and the configuration file is “sys_config.fex”, and after you config your configuration file, you need to use command “fex2bin” to convert “.fex” to “.bin”. Also you could use “bin2fex” to convert “.bin” to “.fex” .

Command tools: http://linux-sunxi.org/Script.bin#Get_bin2fex_utility

image

the fex file description is here: http://linux-sunxi.org/Fex_Guide


#22

Many, many Thanks, Jack!


#23

Hi,

Could you please make a build with Raspbian Stretch Lite? Also, what can I do to get the ethernet port to show when I run ifconfig?

Thank you.


(ZB) #24

Hello, I am preparing to release some other images in few days;

did you mean “ifconfig” in terminal?

I think you could use root user to execute ifconfig in terminal.


[BPI-M2+] New image: Android 7.0 (Version:V1)
#25

I don’t see the eth0 interface when I run ifconfig in terminal, only wlan0.


(ZB) #26

which board do you use?

could please you do “ifconfig” , “bpi-hw” and show me the log?


#27
root@bpi-iot-ros-ai:/home/pi# ifconfig
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:136 errors:0 dropped:0 overruns:0 frame:0
          TX packets:136 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:11472 (11.2 KiB)  TX bytes:11472 (11.2 KiB)

wlan0     Link encap:Ethernet  HWaddr ...  
          inet6 addr: .../64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:108 errors:0 dropped:1 overruns:0 frame:0
          TX packets:123 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:9079 (8.8 KiB)  TX bytes:16528 (16.1 KiB)

root@bpi-iot-ros-ai:/home/pi# bpi-hw
bpi-m2z

(ZB) #28

Hello,BPI-ZERO doesn’t have RJ45 interface,it only has one wireless soc on board, you could connect Internet by WiFi


#29

I will try the solution described here: http://forum.banana-pi.org/t/getting-ethernet-working-with-banana-pi-m2-zero/6137/4. Thank you anyway for supporting this board.


(clemclem) #30

Hello, Thanks for this OS, i use raspbian on my banana pi zero M2 (H2+) and it works great. Except for the wifi that i had to set up manualy with this : http://wiki.banana-pi.org/Getting_Started_with_M2_Zero#WiFi_Client

MY QUESTION is about creating an hostpot with it. I use Raspap (wget -q https://git.io/voEUQ -O /tmp/raspap && bash /tmp/raspap).

All the installation works great, the configuration web page at 10.3.141.1 also works but no WIFI is available using my surrounding devices… Any idea? :frowning:


(ZB) #31

Hello, Did you connect Antenna?

and does sta mode work well on your board?

try “killall wpa_supplicant”.

then do “wpa_supplicant -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf”


(clemclem) #32

i do have en external antenna. I can surf on the internet well. what is sta, how do i check that?

Kill supplicant didnt work


#33

I have some trouble getting bluetooth to work with the raspbian image:

Job for bluetooth.service failed because the control process exited with error code.
See "systemctl status bluetooth.service" and "journalctl -xe" for details.
invoke-rc.d: initscript bluetooth, action "restart" failed.
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2018-11-05 23:43:59 NZDT; 529ms ago
     Docs: man:bluetoothd(8)
  Process: 1694 ExecStart=/usr/lib/bluetooth/bluetoothd (code=exited, status=226/NAMESPACE)
 Main PID: 1694 (code=exited, status=226/NAMESPACE)

Nov 05 23:43:58 bpi-iot-ros-ai systemd[1]: Starting Bluetooth service...
Nov 05 23:43:59 bpi-iot-ros-ai systemd[1]: bluetooth.service: Main process exited, code=exited, status=226/NAMESPACE
Nov 05 23:43:59 bpi-iot-ros-ai systemd[1]: Failed to start Bluetooth service.
Nov 05 23:43:59 bpi-iot-ros-ai systemd[1]: bluetooth.service: Unit entered failed state.
Nov 05 23:43:59 bpi-iot-ros-ai systemd[1]: bluetooth.service: Failed with result 'exit-code'.

Wifi is working fine.


BananaPi BPI-P2 Zero(H2+ with POE) Ubuntu server & raspbian images release 2019-01-16
(Roma Skyser) #34

Hi, Jack! Ubuntu Mate is good! But is good for something more powerful than Zero, with more RAM and… more stable HDMI and more advanced GPU. For this kind of device I need an image of Ubuntu 16.04 but without desktop. So my question - is there such image? I’m developing a PCB for a robot based on ROS. My PCB is designed for use with Raspberry Pi Zero, but I was disappointed with its weakness. And I bought Bpi Zero, because it have the same size, same GPIO pinout and can run Ubuntu, for which I wrote all my software. But Mate is too heavy, I need a clean image without desktop.


(ZB) #35

Hello, I will provide a ubuntu server 16.04 to you

https://drive.google.com/open?id=1yTAJhTdiBlw6pEjoJz_-MOby723xH1VF