Add latest U-boot support for BPI R2 & BPI R64 (not yet)


(weijie.gao) #21

@frank-w Please modify board/mediatek/mt7623/mt7623_rfb.c and replace the board_init with the following codes and have a try:

DECLARE_GLOBAL_DATA_PTR;

int board_init(void)
{
	/* address of boot parameters */
	gd->bd->bi_boot_params = CONFIG_SYS_SDRAM_BASE + 0x100;

	return 0;
}

(Frank W.) #22

Have wondered why this line was dropped,but have not know its reason/function.

I try this when i’m at home

Can you tell me why swig/python-dev is now needed for building?


(weijie.gao) #23

We have switched to binman to generate the final u-boot binary in v3 patches according to suggestions from Simon Glass. And swig and python-dev are required by binman.


(Frank W.) #24

@weijiegao re-adding init-code seems to work well, thank you

any infos about the ethernet-driver? if this is working i can drop the old 2014-uboot


(Frank W.) #25

i tried a bit with emmc-pconfig and it seems i cannot reconfigure it…

after i’ve buyed r2 i had 0x0, after setting (with old uboot) it to 0x48 i had the boot0 and boot1 block

now i read the values with new uboot

U-Boot> mmc partconf 0      
EXT_CSD[179], PARTITION_CONFIG:
BOOT_ACK: 0x1
BOOT_PARTITION_ENABLE: 0x1
PARTITION_ACCESS: 0x0

and tried to set back to 0

U-Boot> mmc partconf 0 0 0 0
U-Boot> mmc partconf 0      
EXT_CSD[179], PARTITION_CONFIG:
BOOT_ACK: 0x0
BOOT_PARTITION_ENABLE: 0x0
PARTITION_ACCESS: 0x0

thought it worked, but after bootup system i see this:

root@bpi-r2:~# cat /proc/partitions                                             
major minor  #blocks  name                                                      
                                                                                
 179        0    7974912 mmcblk0
 179        1     262144 mmcblk0p1
 179        2    7270400 mmcblk0p2
 179        8    7634944 mmcblk1
 179       32        512 mmcblk1rpmb
 179       24       4096 mmcblk1boot1
 179       16       4096 mmcblk1boot0

old uboot shows now

 [EXT_CSD] Partition config      : 0h

also after

emmc pconf 0x48

it stays 0h

isn’t it possible to repartition emmc again? and if yes, is partitioning with

U-Boot> mmc partconf 0 1 1 0

in new uboot the right way to get emmc bootable on R2? (= “emmc pconf 0x48” in old uboot)


(weijie.gao) #26

According to the eMMC spec, there are several hw partitions that can’t be removed (but some can be resized).

The fixed hw partitions are:

Boot 1 -> shown in Linux as mmcblkXboot0

Boot 2 -> shown in Linux as mmcblkXboot1

RPMB -> shown in Linux as mmcblkXrpmb

The two boot partition can be resized. You can use

mmc bootpart-resize

to resize them.

There are also 4 optional configurable hw partitions:

General purpose 1 to 4 -> shown in Linux as mmcblkXgpY

These four partitions are not enabled by default. You can use

mmc hwpartition

to enable and configure them.

All the partitions listed above are addressing from 0.

All the spaces left is the User data partition, which shown in Linux as mmcblkX.

And mmcblkXpY is the software partition created partition table which usually stored at the beginning of the user data partition (MBR or GPT).

As for the emmc partconf command, you should know the PARTITION_CONFIG field of the EXT_CSD register first.

----------------------------------------------------------------------
|   Bit 7  |   Bit 6  | Bit 5 | Bit 4 | Bit 3 | Bit 2 | Bit 1| Bit 0 |
----------------------------------------------------------------------
| Reserved | BOOT_ACK | BOOT_PARTITION_ENABLE |   PARTITION_ACCESS   |
----------------------------------------------------------------------

BOOT_ACK means whether to send ACK during boot.

BOOT_PARTITION_ENABLE determines which partition to access during boot. The following values are valid:

0 - Disabled
1 - Boot 1
2 - Boot 2
3 to 6 - Reserved
7 - User data

PARTITION_ACCESS determines which partition to access now:

0 - User data
1 - Boot 1
2 - Boot 2
3 - RPMB
4 to 7 - General purpose 1 to 4

So, back to your question:

emmc pconf 0x48 in the old u-boot means BOOT_ACK = 1, BOOT_PARTITION_ENABLE = 1, PARTITION_ACCESS = 0, which is the same as mmc partconf 0 1 1 0 in the new u-boot.

So

mmc partconf 0 1 1 0

is really the right way in the new u-boot.

The boot partitions always exist no matter what value you set using emmc pconf/mmc partconf.

Please note that mmc partconf 0 will display incorrect value (the PARTITION_ACCESS field) if you use mmc dev 0 1 to switch partition.

P.S. You can set BOOT_PARTITION_ENABLE = 2 if you want to burn preloader into Boot 2.


(Frank W.) #27

Thanks for clarification…now i know the meaning of 0x48

01001000 = bit 3 (PARTITION_ENABLE - boot1) and bit 6 (boot_ack) set

i just wondering why emmc ecsd always showing 0x0, also after setting pconf to 0x48…i did not a partition switch via “mmc dev x y”

new uboot shows right setting after doing it…so all good :wink:

Nice,so the only thing i miss is the ethernet-driver which may be complex due the switch (mt7350) appended to soc.We do not need a dsa-driver. Imho setting hwaddress should work (maybe bypass to kernel,so this does not generate a random one)